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Chapter 1.

Advanced Program Features

Introduction

This user guide introduces you to the advanced features included in
eXtendia.

eXtendia is one of the most powerful Web-based application creating tools
available. It enables you to create dynamic Web-based applications to
work on a variety of Web servers powered by UNIX or Windows operat-
ing systems and database servers.

Using eXtendia’s Dynamic page Editor, you can easily create and develop
dynamic pages for your Web application, and only while generating the
final resources; you select ASP or JSP as the output server side scripting
language, in order to make them work with the Web server you use.

Note: If you are planning to develop dynamic components for your Web
application, you should code using your target output language (ASP or
JSP) as eXtendia will not translate your custom components from ASP to
JSP and vice versa. See the section on Dynamic Component Library
later in this chapter.

eXtendia is a completely new product designed for enterprise applica-
tions. To maximize your use of eXtendia we recommend that you install
the software with all of its components. The minimum installation (i.e.
installing the basic system without most of the optional components) will
occupy 115 MB of hard disk space, while the full installation will occupy
330 MB. If you have enough hard disk space, we recommend that you
install eXtendia with all of its components.

Refer to Installation Instructions found in the Main User Guide to install
the eXtendia development system on your computer.

This chapter will introduce you to the following new components and fea-
tures:
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• Positioned Hidden Variables

• Dynamic Component Library

• The File Control Form Field

• Text Line Validation

• Image Style

• Image Button

• Table Style

• Delete Unnecessary Files

Positioned Hidden Variables

Hidden variables are variables that are generated or used in the ASP, form
codes, or dynamic pages of the Web application. In other versions of the
program, the hidden variables are inserted in the front of the form. How-
ever, there are instances that you may want to insert a hidden variable in
other places in the code. eXtendia enables you to do this with the new
Hidden Variables feature.

This provides you (the Web-based application developer) with great new
capabilities. Some examples of where you may have a need for this are: if
the form has to send a value to the next page, or use a value which is not
entered by the buyer but one that is created by the dynamic page code
based on certain inputs or criteria. These could be fixed variables that you
have entered in the dynamic page code to be used under certain condi-
tions, or they could be variables or data generated by the dynamic page
code in real time based on certain events.

When using WebShop (i.e., one of the previous versions of eXtendia), in
both cases, such variables or data are automatically placed in the front of
the form using the Form Property dialog box. In this case the hidden vari-
ables are associated with the actual form code.

With eXtendia, the hidden variable is still associated with the form, and is
still inserted automatically by the program, but you can insert this code
anywhere in the form code you want, for example in the middle of the
form code.

For example, if the code is reading records from the database,
record-by-record in a cycle, and puts these records on the Web page, you



Additional Program Features

Additional Features 1 - 3 �  �  �

can now place a button next to each record that can get and display more
information about that product or database item. If the visitor clicks on
such a button, the form gets or posts another page with parameters and
hidden variables and displays a different Web page with the detail infor-
mation. In such a case the hidden variable must be in the same cycle of
the code. You can do this by using the Positioned Hidden Variables fea-
ture.

To do this, first create a dynamic page with a database driven table in it.
Refer to the Database Driven Table section in the second chapter for more
details. Assign a hidden variable to a form field that will appear in each
row of the table such as a check box or a submit button. Now (when
displayed) the hidden variables in each row may hold specific values for
each record.

In previous versions of the program you may have been able to do this but
with lots of special programming, where the dynamic page code would
perform these functions. It was difficult to manage the process and make
sure it works properly all the time. Now eXtendia achieves this more ac-
curately and with much less development work.

Dynamic Component Library

WebShop included the option to insert custom dynamic page scripts that
could be used in regular Web pages. The Dynamic Component feature is
similar to custom scripts yet much more powerful. It is designed to be
used in dynamic pages and enables you to code specialized and more
complicated server side scripts.

With eXtendia’s JSP dynamic page creation, you can write custom dy-
namic components in JSP to be used with your JSP Web-based applica-
tions.

When creating dynamic components in eXtendia, you must first decide
what your Web application's host environment is. This is necessary to
choose between JSP and ASP as your Web application output language.

If the target Web server is JSP compliant or the server operating system is
UNIX, you must select JSP in the Dynamic Component Editor and type
JSP code for your components, as well as select JSP as your output type
while generating your Web-based application’s resource files.

If you are planning to generate your Web application for both ASP and
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JSP, you may select the language from the drop-down box in the Compo-
nent Editor's general tab and type your code in appropriate language in the
Body tab, then you can repeat the procedure for the other language.
eXtendia will use the proper component code for the generate-time output
type.

Although more powerful, creating and using custom dynamic components
requires you to be familiar with ASP or JSP coding. See the example at the
end of this topic.

A dynamic component, therefore, is a custom program or query written by
you in ASP or JSP, which is not created or generated by the program's built-
in Dynamic Page Editor. The ESGs that are created by Boomerang Soft-
ware and work with eXtendia include their own Dynamic Components.

One of the most exciting benefits of this feature is the ease of repeating a
custom component in more than one page. For example: If you want to
display the date or any dynamic data in the top of every page of your Web
application, instead of inserting the appropriate code in every page, you
can create a dynamic component, save it in the Dynamic Component Li-
brary, then use the Dynamic Page Editor's Manager window and insert it
wherever you want.

eXtendia enables you to create, modify and organize the dynamic compo-
nents you create with the use of the Dynamic Component Library.

You can create as many dynamic components as you want. The program
ESGs (Enterprise Solution Generators) include many dynamic compo-
nents that you can check to see how this feature works.

For example, the E-Commerce Offline-Online template and ESG includes
a number of dynamic components that are used in the actual application.
To see some of these dynamic components, open the E-Commerce ESG
or template, and select Library > Edit Dynamic Component Library
menu.

The Dynamic Component Editor dialog box appears. Click on any of the
listed components in the Component Name list, and click on the different
tabs to examine the details of that component. You may edit the specific
component if you like, or create your own and add it to the library of
components.

If you are starting a brand new project, you may want to create your own
dynamic components and build your own library.
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The following sections describe the details of each tab and the fields of the
Dynamic Component Editor dialog box:

General Tab
• Folder Path: Displays the full path of the destination folder where the

current dynamic component is created. You cannot modify this data.

• File Name: You must enter the name of the Dynamic page you have
opened for editing.

• Component Name: You must enter the name of the dynamic compo-
nent you want to create. If you select an existing component from the
Component Table, this field will display the name of that component.

• Component Description: You may use this field to add some notes
about the component you are creating.

• Component Version: Displays the version of the component. The
default value is "Version 1.0”.

• Type: Here you can select whether you want to create or modify a
program or query component.

Figure 1.1 Dynamic Component Editor - The General tab
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• Scripting Language: Enables you to select the server side scripting lan-
guage for the component code that you want to insert in the Body tab.

• Component Table: Lists the components that exist in the folder that
appears in the Folder Path field.

• New button: Enables you to create a new component.

• Save button: Saves the dynamic component you have created or modified.

• Delete button: Deletes the selected dynamic component.

Inputs Tab
Enables you to add, modify and delete input parameters for the selected
dynamic component.

Click the Add button to bring-up the Add dialog box where you can de-
fine the Item name, its description and type.

The Modify button is active if an existing parameter is selected. Click on it
to bring-up the Modify dialog box, where you can modify the settings of
the Dynamic Component i.e. name, description and type.

Figure 1.2 Dynamic Component Editor - The Inputs tab
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Outputs Tab
Similar to the Inputs Tab, the Outputs Tab enables you to add, modify and
delete output parameters for the selected dynamic component.

Body Tab
Enables you to manually modify the component parameters by writing and
entering actual code yourself. You may use the upper window to copy and
paste the component's input and output parameters for quicker develop-
ment and to void typing errors.

Example
Let us say you want to add the date on every page of your Web applica-
tion. To do this:

1. Open your Web application project by selecting the File > Open... or
start an empty project by selecting File > New and selecting the big X.

2. Create a dynamic page by clicking in the Site Manager window and
selecting Physical Layout > Create Dynamic Page. Save it under
the name "test.asp".

Figure 1.3 Dynamic Components Editor - The Outputs tab / Modify dialog box



Chapter 1

eXtendia1 - 8  �  �  �

3. Select Library > Edit Dynamic Component Library... The Dy-
namic Component Editor starts-up.

4. Make sure the Type radio button is set to Program.

5. Type-in the File Name* field DateEntry. This is the name of the
file that holds your component and is stored on your hard disk.

6. Type-in the Component Name* field InsertDate. This is the name
of the component that you will use while building this Web application.

Note: The "File Name" and "Component Name" can hold the same
value. However, in some cases, you may want to give them different
names.

7. Describe this component in the Component Description field to make
sure you can find it easily in the future.

8. Let's assume you want the date to be displayed in red. However,
under certain circumstances the color may be changed as indicated in
strDateColor, which has a dynamic value (i.e. can be changed
by dynamic pages or the server). To do this, select the Inputs tab.

9. Click Add. The Add dialog box appears.

Figure 1.4 Dynamic Components Editor - The Body tab
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10. Type in the Item Name* field strDateColor. We assume that
either you already have such a parameter used in your Web applica-
tion or you will define it here and use it from now on.

11. Fill in the Description field.

12. Make sure the Type radio button is set to String. Click OK.

13. Select the Body tab. In the lower textbox, enter the following code:

vDate = Date()
Response.Write("<FONT color=#")
Response.Write(strDateColor & ">")
Response.Write(vDate)
Response.Write("</FONT>")

14. Click OK. A message prompt will ask you if you want to save the
changes. Click Yes.

Note: Anytime you want to review your component, select Library > Edit
Dynamic Component Library.

15. From Site Manager's Physical Layout window, double-click on
'test.asp' (that you have created in step 2) to open it.

16. In the manager section of the Dynamic Page Editor, right-click on
ROOT and select Add Into > Component. You can see the compo-
nent icon attached to ROOT.

17. Double-click the component icon and the Component Properties dia-
log box appears.

18. From the Choose component drop-down box select InsertDate.

19. From the Input parameters tab double-click the strDateColor. The
Modify dialog box appears.

20. In the Value tab, Insert Value textbox, insert the value ff0000. Click
OK both in Modify and Component Properties dialog boxes.

21. Generate your Web application and test it as you usually test your
dynamic pages. The result will be an empty page that displays the
date in red.

The File Control Form Field

The File Control Field is an element that can be added to a form. You can
use it to enable the visitor to browse or point to the path or to a local file.
The visitor can type the path in the text box, or click the Browse...  but-
ton, navigate and point to the file.
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Important Note: For this control feature to work, the eXtendia COM
objects must be properly installed on the server where your Web appli-
cation is located. Contact your server’s administrator and make sure
this is done. If COM objects are not installed, refer to the chapter on
Server Related Topics to learn more about this. It explains how the
COM objects can be installed on the server.

1. To insert a form in a page, first select Insert > Form  from the menu.

2. To insert the File Control select Insert > Form Field > File Con-
trol...  The File Control Properties dialog box appears.

3. In the Name field type in a name for the File Control.

4. Type in or change the value of the Field Size field by clicking on the
increment or decrement buttons.

5. Click the Advanced...  button if you want to perform advanced op-
erations with HTML coding and scripting. The Advanced Web Op-
erations dialog box appears. Enter any special or advanced code that
you want.

6. Click Hidden Variables...  if you need to assign the hidden variable
parameters such as Name and Value to this selected Form compo-
nent. The Hidden Variables dialog box appears. Click Add...  In the
Add Hidden Variable dialog box type in a name and a value and
click OK.

Text Line Validation

The Text Line Validation dialog box enables you to have the input form
on the web page validate data being entered by the visitor.

In the Display name field enter any text that the form field will display as
a default text in the form. This appears when the form is displayed.

Figure 1.5 The File Control Properties dialog box
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In Data type  combo Drop-down box, select one of the validation criteria
to be performed on that field. The criteria options include:

• Ignored

• Text

• Integer

• Decimal

In the Data Length  section you may check the Required  checkbox if
you have specified text data for the Data type . Enter numbers in the Min
Length  and Max Length  value fields. This will force the visitor to enter
an alphanumeric string which is no less than and no greater than the length
in characters that you specify.

In the Data Value  section you may enter the acceptable conditions or
criteria that you want to apply to the visitor’s inputs. Use Field must be
and And must be  check boxes, operation selectors and Value  data boxes
to set the limits for the data entered by the visitor. If the visitor enters data
that does not comply to the criteria you specify, the data is not accepted
and the user is prompted to try again. The operations include:

<  if the Field value is less than the right operand of binary operation

<=  if the Field value is less than or equal to the right operand of binary
operation

Figure 1.6 The Text Line Validation dialog box
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<>  if the Field value is not equal to the right operand of binary operation

=  if the Field value is equal to the right operand of binary operation

>  if the Field value is more than the right operand of binary operation

>=  if the Field value is more than or equal to the right operand of binary
operation

Click OK after you specify all the criteria that you want.

Click Cancel  to quit.

Image Style

To access the Image Style dialog box (Figure 1.7), go to the Styles Lay-
out in the Site Manager window and double-click the Image Style sec-
tion. This feature enables you to set an image style for the entire Web
application. This image link will be available on every web page of your
Web application.

To assign a new image style, first fill out the Image Style Group  field.
Click Add . Click on Rename  or Delete  buttons if you want to rename
or delete the currently selected image style.

Figure 1.7 The Image Style dialog box
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Select an image resource that should be assigned to this specific Image
Style. To do this, select an image from Image Resources  panel by
clicking Existing Resources , Library  or URL, respectively. You can
also use the Import... , Create  and Acquire...  buttons to get images.
These enable you to browse and import, create an image using the avail-
able images on your PC, or acquire an image from scanners or digital
cameras.

Click OK when done.

Click Cancel  to quit the dialog box without saving the changes.

Image Button Form Field

It is sometimes more interesting to use image buttons instead of regular
buttons in Forms. Furthermore, eXtendia enables you to assign hidden
variables to Image buttons, whereas under normal circumstances, regular
buttons cannot perform this function.

To insert an image button click inside a form area and select Insert >
Form Field > Image Button... The Image Button Properties dialog
box appears (Figure 1.8).

Figure 1.8 The Image Button Properties dialog box



Chapter 1

eXtendia1 - 14  �  �  �

Table Style

eXtendia enables you to create or modify visual settings for table objects
that you want to use in the design of your Web application. You can access
the Table Style dialog box (Figure 1.9) from the Style Layout by double-
clicking the Table Style section.

To start creating a new style, go to the Style Layout in the Site Manager
window. From the Site Styles section select the style that will include the
new table style. Scroll down the right pane until you see the Table Style
section. Double-click on it. The Table Style dialog box appears. Place the
cursor in the Table Style Group section and enter the name of the style
you want to create.

To start working on an existing table style, click on the drop-down arrow from
the Table Style Group section and select the table style you want to modify.

The Cells Group drop-down list enables you to set the visual appearance
(background and text colors) of various cell groups listed in the dialog box.
These are the Header, Footer, Body Rows, and Patterned Row.

To edit a cell group color, double-click on the corresponding color box in the
Cells Group section to access the Color dialog box of the program.

Figure 1.9 The Table Style dialog box
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If you check the Alternative Body Row Colors checkbox, the table will get
a striped or patterned style.

Delete Unnecessary Files

As you work on your Web-based application, evolve it, edit it and modify
it, inadvertently you end up having resources or files in your Web applica-
tion project that are no longer needed or no longer used by the Web appli-
cation. They remain in your project unused, simply taking up space and
creating confusion. eXtendia enables you to cleanup your Web application
project by accurately removing such files.

This removes unnecessary files, reduces the amount of space your Web
application requires, speeds up the publishing part of the Web application
and may save you money if you are being charged for hosting your Web
application, based on the amount of space your Web application uses.
eXtendia searches the entire project and automatically finds which files
are or are not used, and removes the ones that are not used.

To remove the unnecessary files from your project before you publish
your web project to the server, select the Site Analyzer window then se-
lect Physical Layout > Delete Unused > (the type of unneces-
sary files you want to delete) .

Important Notes:

1. Before you perform this operation make sure you have backed up your
Web project files in a separate folder on your PC. In case the clean up
process breaks anything, you can revert to the Web application ver-
sion that works.

2. Some files are dynamically called to be used only by dynamic pages.
If this is the case in your Web application, then be very careful and do
not delete such files. Especially DO NOT use this feature for the type
of files your dynamic pages call.

3. Remember that this feature deletes files from eXtendia project or
Web application located on your development PC. If you already have
published your Web application to the server and then perform the
Delete Unnecessary Files operation, it does not delete files from your
Web application on the server. When you do a Site Publish or upload
your Web application to the server, and if a previous version of the
Web application exists on that same server, then the new uploaded
Web application overwrites the existing one but it does not delete the
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unnecessary files on the server. To clean up the Web application on
the server, you must first delete the Web application (not the data-
bases) then upload or publish the new cleaned up one. It is also rec-
ommended that you back up the Web application on the server before
you publish a cleaned up new Web application, just in case you delete
a page or resource that you should not have, then you can always
restore the original Web application while fixing the problem.
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Working with Different Databases

Introduction

This chapter introduces you to the following new concepts and features:

• Working with Oracle, MySQL, or MS SQL Databases

• Database Driven Tables

• Database Query Functions

eXtendia enables companies to build Web-based applications that tie into
their existing databases. eXtendia, itself, uses the MS Access database as
its inner default database. If you start with a pre-designed eXtendia Solu-
tion Generator to create your eXtendia project, it will create or use its own
MS Access .mdb database file.

This does not mean that you may not use another external database. You
can create your own database with its own database schema or structure
using the Microsoft Access program. You can also use an existing Access
database file, which has its own database schema or structure. In either
case, you can import the database structure into eXtendia. This will en-
able your Web application to access and use your existing or newly cre-
ated databases.

In such cases, when publishing your site, the database file (for example
ShopDB.mdb), will be uploaded to your Web location along with your
site content. You can choose to generate or publish only parts of your site,
and in particular you may choose to publish the site without uploading the
database.

eXtendia generates the ASP or JSP code for the dynamic pages you cre-
ated using the Dynamic Page Editor. These scripts enable your site to
interact with site database(s).
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If you have Oracle or MS SQL databases already created and operational
on a server accessible to you and your generated site, eXtendia enables
you to work with them as well.

Working with Oracle, MySQL, or MS SQL Data-
bases

eXtendia needs to get introduced to the database structure, which will be
used for the site or the Web-based application.

Besides the ability of working with MS Access databases, eXtendia en-
ables you to create Web applications that work with your existing data-
bases that reside on MS SQL, MySQL, or Oracle database servers. To
create a Web site or Web-based solution that uses an MySQL, Oracle, or
MS SQL database, you must first import those database structures into
eXtendia.

In order to enable eXtendia to work with your database structure, you
must import the database in eXtendia. Database import from an MS SQL,
MySQL, or Oracle database will import only the database structure and
not the database data. After the database import is done successfully, you
will be able to design queries to that database in your dynamic pages.
eXtendia will code your dynamic pages appropriately in order to make
them able to connect to your target database table fields.

To import a database structure

1. Create a folder in the Site Manager - Physical Layout and name it
"database".

2. Select the newly created database folder and right-click inside it. From
the pop-up menu select Import Database… The Database Connection
dialog box appears.

3. From the Database & Provider Type drop-down box select your source
database type.

4. To import an MS Access database click OK. The Open dialog box
appears. Browse and select the MS Access file and click Open.

5. For MS SQL or Oracle databases fill out the form and click OK.

Note: In the Schema field, you must insert the schema name (for MS
SQL the owner name) where the tables you want to import reside.
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6. If eXtendia was able to connect to the database server by the login
information you provided, the Import Database Tables dialog box ap-
pears. Check out the tables you want to import and click Import. You
will see several messages displayed in the Messages tab that provide
information about the import procedure.

7. When the database import is over, a message indicates that the data-
base import finished successfully. Close the Import Database Tables
dialog box and the imported database is inserted into your project in
the MS Access format.

When the import process encounters any problem, an error message ap-
pears and asks you whether you want to continue the import process or
abort it. If you click Yes and select to continue importing the database,
after finishing the import process, eXtendia indicates the error(s) occurred
during the import process. If you are satisfied with the results regardless
of the errors encountered, click Apply and the database structure is im-
ported to your eXtendia project.

Once you have imported your database structure into eXtendia, you can
start building your Web-based application. It does not matter that the da-
tabase is mostly empty. The fact is that it matches the actual or real data-
base structure that you will eventually use. After you complete building
the Web project, publish or generate it. Do not use the empty or dummy
database generated by eXtendia, instead delete or remove it from the Web
application and use the real Oracle, MySQL, or MS SQL database in-
stead.

Important Notes on Importing Databases
You can import an Oracle, MSSQL, or MySQL database into eXtendia if
data tables contain fields, and where the data types are convertible to MS
Access data types. For example:

• The Oracle 8 data types: BLOB, CLOB, NCLOB, BFILE do not
have their analogs in MS Access. In old databases, these were used
to keep images or complex binary objects instead of URLs referenc-
ing various types of objects. The more efficient database structures
organize the data where URLs are used in the database instead. Note
that you can still use these with eXtendia, using the program’s custom
dynamic components and custom query components features. These
enable you to perform any action that you like including extra ASP or
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JSP components or other code.

• The Oracle data type ‘number’ is translated to its corresponding MS
Access data type if its precision value is  between 1 and 28.

• When importing tables all database constraints, such as UNIQUE,
CHECK, PRIMARY KEY, FOREIGN KEY are discarded and only
the fields’ attributes are transferred.

Note: To see how eXtendia converts data types while converting data-
bases to other types, refer to Appendix B “Data Type Conversions.”

Exchanging Data among MS Access, MS SQL,
MySQL, and Oracle Databases

Using eXtendia, you can easily create a Web-based application, which is
capable of performing sophisticated data exchange among several data-
base servers of various types, regardless to the operating systems they are
running on, and the physical location of the servers.

To realize such a project, you should first import database structures into
eXtendia and then create a dynamic page that retrieves data (SELECT
query) from one or more databases and then performs INSERT, UPDATE,
DELETE or custom queries to other databases.

Note: For instructions on converting an existing database to another
format, read the chapter “Converting Databases” in this user guide.

Database Driven Tables

A Database Driven Table is a table that displays data read directly from a
database. It attaches the requests made to the Web application’s database
to the tables on the visitor’s web pages. An example is an Internet search
engine's search results page. Without this advanced feature, the designer
of a web application, must not only query the database, based on visitor
request, but also handle the results and place them in an organized format
on the browser screens. This includes displaying the data without loosing
any information, placing them in columnar and row format and to contend
with other report-like layout challenges. The Database Driven Tables of
eXtendia automate all this and provide embedded queries to tables. With-
out any programming, it enables the web application developer to place
data gathered from the database directly on the web pages quickly and
efficiently.
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This feature is available only on dynamic pages.

To create a database driven table

1. While you preview a dynamic page’s feedback section, select Table
> Insert Table...  The Table Properties dialog box appears (Figure
2.3).

2. In the Cells section, specify how many rows and columns you want
the table that will display the database query data to have.

Note: The Number of Rows is equal to the sum of the number of
header lines and the number of rows that should be reproduced by
each iteration. Unlike caption, header, and footer lines, in a database
driven table the rows are repeated as long as the query returns values.
For example, if you set the Number of Rows field equal to '4' and '1' for
each of the Header Rows and Footer Rows, the table created will
produce two rows for each query iteration.

3. Select the created table, then select Format > Object > Query Wiz-
ard... from the menu, or right-click on the table and from the pop-up
menu choose  Object > Query Wizard...

Figure 2.3  The Query Properties dialog box - The Select tab
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4. From the Choose Data Source for New Query dialog box (Figure
2.3) find and select the source database.

5. From the drop-down box select the Query type: SELECT.

6. Press the Edit Query  button.

7. In the Query Properties dialog box, from the Tables drop-down box
(in the Select tab) select the table you want.

8. From the Available Fields list box select the fields you want to use in
the table and click Add . Click OK.

9. Click in the cell that will hold the data. From the menu select Dy-
namic Page > Insert Dynamic Element...

10. Double-click the element to insert it.

11. While the Dynamic Elements dialog box is still open, click any-
where on the page that you want to insert the other elements and
insert them. Click Close .

Database Query Functions

Query functions are used to access the database records. Almost all ac-
cess to databases is done through queries. For example: reading a record
from the database is done with a query command.

This can be done in a dynamic page. Open the dynamic page, in the Logi-
cal tree, insert or add the command Query where you want to execute a
query to the database. The program inserts a Query action item in the
logical tree.

Double-click on this Query action item. The Query dialog box opens. It
lists the specific query actions you can perform. These include: Select,
Insert, Delete, and Update.

Choose one of the options for example "Update” and set the table names,
field names or other details. Click OK. It inserts these into the Query
action item.

When this dynamic page is called by the browser, the Query action item is
executed at the proper sequence in a top to bottom execution list, and the
access or update to the database is done.

You can use a Query to read one record from a database or many records.
In the case of many records, right-click on the Query action items in the
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Manager window of the Dynamic Page Editor, and select Record Set. It
inserts the Record Set action item as a subset to the Query action item.
This forces the program to access a record and execute the actions you
list below on in the loop of the Record Set, then it accesses the next record
in the database, and executes the actions again. This loop continues till the
end of the specified table, unless you insert other conditions which you
can specify in the Query dialog box.

Example:
If you insert a Feedback Section command inside the Query loop, and if
the database has three records, then when this dynamic page and its Query
is executed, the browser page will show three tables, one after the other,
one for each record. If you have inserted other action items in the same
loop, then those results will be displayed in sequence along with the three
tables.

Why Are Queries Needed?
You can use queries to find, retrieve, update, delete, analyze, or perform
calculations on the data you want from the entire database. You can also
use them as the source of records for forms, and reports.

What Types of Queries Are There?
Delete: Deletes one or more records from a database.

Insert: Adds a new record to a specified field of a database table.

Select: The most common type of queries is the select query. It retrieves
data from one or more tables by using criteria you specify and then
displays it in the order that you want.

Update: Updates the records you want in a database.

Besides these query types, eXtendia enables you to create more custom-
ized queries by creating dynamic objects (See the section on dynamic
components in the first chapter).

What an Embedded Query Is All About?
Embedded queries are used to create database driven tables or bring dy-
namic contents into drop-down (combo) boxes. You can create embedded
queries only in a dynamic page’s feedback section.
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Note to all upgrade users or who have used previous versions of this
program: The Embedded Query solution of eXtendia is more powerful
than the methods used in the older versions. It is recommended that
you read the sections on how to create an embedded query and em-
bedded queries’ advantages to learn more about these new features.

How to Create an Embedded Query
The following steps explain how an embedded query is implemented in a
dynamic page:

1. Select File > New. The New dialog box appears. Double-click on the
big X to create an empty Web project.

2. In the Site Manager window create a folder in the root directory and
call it “Databases”.

3. Select this folder and select Physical Layout > Import Database...

4. Browse and point to the database you want to build the query on and
click Open. This example will use a database called ShopDB.mdb
(i.e. the E-Commerce database of one of the program's ESGs or tem-
plates provided, which you have installed during the installation of
eXtendia. Otherwise open the ESG file (CNQ) from the program folder
or the program CD). In general, you can use any database you want as
long as you convert it to MS Access format (with an .MDB exten-
sion) and add or insert at least one table with fields and records.

5. Now go back to the root folder of your Web application and press
CTRL+D to create an empty dynamic page. Call it “SmpQry” or
any name you want.

6. To edit SmpQry double-click on its icon. The Dynamic Page Editor
appears.

7. Right-click on the ROOT and select Add Into > Feedback Section.
Click on the Feedback Section Icon in the tree view. The grid in the
right pane will be replaced by a blank white page.

8. Click in the blank page and select Insert > Banner.

9. To give this page a more meaningful name than SmpQry, click on >>.
Right-click on the SmpQry icon and from the pop-up menu select
Resource Properties...

10. In the Properties dialog box check the Alias checkbox and replace the
textbox content with Sample Query. Click OK. Note that the banner
text is updated now. The alias name is used by eXtendia to create
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page banner or navbar text.

11. Select Table > Insert Table. The Table Properties dialog box ap-
pears.

12. For the Header Rows insert the value 1 and select the Pixels radio
button for the Width. Click OK.

13. The created table should have two rows and two columns. The upper
row represents the header row. Anything you enter here will exactly
appear in your dynamic page as the header row of your table. Leave
it blank at this time.

14. It is time to create the embedded query. Click outside of the table to
exit the table edit mode. Click on the table to select it. Select Format
> Object > Query Wizard... from the menu,or right-click on the
table and from the pop-up menu choose  Object > Query Wizard...
The “Choose Data Source for New Query” dialog box appears.

15. Double-click on the Databases folder in the explorer section and se-
lect the database file you want to create the query on. Leave the
Query Type as SELECT and click Edit Query. The Query Proper-
ties dialog box appears.

16. In the Select tab, click and open the Tables drop-down box and select
the table you want to retrieve data from. The fields available in that
table appear in the Available Fields list box.

17. Select the fields you want and click Add > or double-click it to insert
it to the Selected Fields list box. In our example we have selected the
ProductName and UnitPrice fields from the Product table. Click OK.

18. Click inside the leftmost cell in the header row (i.e. the upper one in
the table) until you see the blinking cursor. Type in “Product Name”
and “Price” in the header cells successively.

19. Select Dynamic Page > Insert Dynamic Element... The Dynamic
Elements dialog box appears (Figure 2.4).

20. With the Dynamic Elements dialog box open, click inside the body
cell where you want to insert the dynamic element. You will see the
blinking cursor. Turn back to the Dynamic Elements dialog box and
select the field you want to include in the selected cell. In our example
we have selected Query_1.Products.ProductName. Click Insert.

21. Repeat the last action for the other cell(s) and click the Close button.

22. You are ready to preview the dynamic page you have created. Gener-



Chapter 2

eXtendia2 - 10  �  �  �

ate your Web application by pressing F8 to your Web server, and
preview your dynamic page as usual, using an Internet browser (not
the built-in Site Preview function) through the HTTP protocol.

If you have followed the explanations carefully, then the resultant page
will be similar to the one in Figure 2.5.

Embedded Queries’ Advantages
In the previous versions of the program, if you had checked the "Repeat
the whole section for each feedback record" option in the Advanced Web
Operations dialog box (Dynamic Properties tab: Figure 2.8), then the page
displayed on the browser would have three separate tables one for each
record.

Such earlier versions had difficulty handling Feedback Section results where
the Form and the table were in one another. eXtendia gives more flexibility
and generates more accurate layout of information. In eXtendia the Dy-
namic Properties is not needed and is not available. The same results are
obtained by using the Embedded Query options.

Figure 2.4 The Insert Dynamic Elements dialog box
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Figure 2.5 The result of the Sample Query page

To do this insert a Feedback Section in the Dynamic Page Logical tree
anywhere you want.

Select it and build in it the table, as you want it.

Select the table, then select Format > Object > Query Wizard... from
the menu, or right-click on the table and from the pop-up menu choose
Object > Query Wizard...

This designates it as an Embedded Query.

Embedded queries are executed each time the Feedback Section includ-
ing them is executed.

This gets the information from the database, and places it on the Web
page in one table, with one header and footer (optional) and with rows that
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include and match the records received from the database. The table will
be followed by the Feedback section elements (if any).

The Embedded Query feature makes creating nested database driven tables
easy by simplifying the algorithm of their dynamic tree.

Custom Report Layouts
The common method of displaying embedded query results in a data-driven
table is one record per row. However, eXtendia allows you to display
multiple records in a single row.

1. Create a table with multiple columns, and insert an embedded query
into it. See the section on Embedded Queries in this chapter.

2. Insert one or more dynamic elements that the query returns in the first
cell.

3. Repeat step 2 for the other cells in the table.

4. Select the table, right-click on it and select Object > Query Wiz-
ard…

5. From the Query Properties dialog box go to the Feedback tab and
select All records from the Page size section.

Figure 2.6 The Advanced Web Operations Dialog Box: The Dynamic Properties Tab
Exists Only in WebShop
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Figure 2.8 Repeat the Whole Section Checked in WebShop

Figure 2.7 The Dynamic Tree of a Database Driven Table in WebShop

6. Check the checkbox named "Check to enter columns number in a
row". A spin box appears. Set its value to the table columns' number.

When you generate your Web application and load the dynamic page, the
query will return a table with the corresponding number of columns in a
row and one record in each cell.
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Chapter 3.

Converting Databases

Introduction

eXtendia enables you to convert your existing databases to another data-
base format. Using the Database Conversion feature of the program, you
can:

• Convert an MS Access database to a database structure of MS SQL,
MySQL, or Oracle.

• Convert database structures of MS SQL, MySQL, or Oracle to an MS
Access database.

Database Conversion from MS Access to MS
SQL, MySQL, or Oracle

You can convert databases when you generate or publish your eXtendia
Web project. To convert an MS Access database to a database structure of
MS SQL, MySQL, or Oracle, you must have that Access database already
imported into your eXtendia Web project.

In order to be able to convert your MS Access database to MS SQL Server,
MySQL, or Oracle, the following requirements are necessary:

• The Client computer must have a standard Windows configuration.

• A Web server must be installed and running on the Server computer.

• To convert an MS Access database to an Oracle database structure,
you need Oracle Client installed on your system (for ASP type of
Dynamic pages).

• To convert an MS Access database to a MySQL database structure,
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the MySQL ODBC driver must be installed on your system (for ASP
Dynamic pages). The MySQL ODBC driver can be downloaded from
www.mysql.com.

• If your Web site uses JSP Dynamic pages, the appropriate JDBC driv-
ers must be installed on your system.

The following example demonstrates how to convert the MS Access data-
base of your Web project to the database structure of MS SQL Server,
MySQL, or Oracle:

1. Select File > New to start a Web project.

2. Go to the Site Manager > Physical Layout.

3. Choose a folder location where you want to create (or import) the
database resource, right-click on it, and select Import Database...
from the pop-up menu.

4. In the Database & Provider Type drop-down list, select MS Access
and click OK. The Open dialog box appears.

5. Select the Access file you want to import and click Open. The data-
base resource appears in the Physical Layout.

6. Select File > Generate Site.

7. Select the Advanced option and click Next.

8. Select the platform and the language for site generation scripts and
click Next.

9. From the tree of Web resources (files), select the database you want
to generate.

10. Click Next.

11. From the Databases Generation Mode step of the wizard, select the
appropriate database name and double-click on it. The Database Con-
nection dialog box appears. Select the database type you want to gen-
erate. For MS SQL Server, select either MS SQL Server or MS SQL
(ODBC). For Oracle, select either Oracle SQL Server or Oracle SQL
Server (ODBC). Select MySQL Server for MySQL.

12. Enter the appropriate information in the dialog box fields. When done,
click Next.

13. Select the folder destination for your Web site and click Next to gen-
erate (publish) your site.

14. Once your Web site is generated (published), run the .HTM file that

https://www.boomerangsoftware.com/webhosting/webhosting.htm
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contains the database generation scripts. This file adopts the name of
the database resource. For example, if the MS Access database of
your Web is ‘sample.mdb’, the database generation scripts are saved
as ‘sample.htm’ and ‘sample.asp’ or ‘sample.jsp’ files.

Database Conversion from MS SQL, MySQL,
or Oracle to MS Access

You can convert databases when you generate or publish your eXtendia
Web project.

To convert the database structure of MS SQL, MySQL, or Oracle to an
MS Access database, the following requirements are necessary:

• The Client computer must have a standard Windows configuration.

• To convert an Oracle database structure to an MS Access database,
you need Oracle Client installed on your system.

• To convert a MySQL database structure to an MS Access database,
the MySQL ODBC driver must be installed on your system. The
MySQL ODBC driver can be downloaded from www.mysql.com.

Note: To see how eXtendia converts data types while converting data-
bases to other types, refer to Appendix B “Data Type Conversions.”

The following example demonstrates how to convert an MS SQL, MySQL,
or Oracle database structure of your Web project to an MS Access data-
base:

1. Select File > New to start a Web project.

2. Go to the Site Manager > Physical Layout.

3. Choose a folder location where you want to create (or import) the
database resource, right-click on it, and select Import Database... from
the pop-up menu.

4. In the Database & Provider Type drop-down list, select Microsoft
Access and click OK. The Open dialog box appears.

5. Select the Access file you want to import and click Open. The data-
base resource appears in the Physical Layout.

6. Select File > Generate Site.

7. Select the Simple option and click Next.

https://www.boomerangsoftware.com/webhosting/webhosting.htm
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8. From the tree of Web resources (files), select the database you want
to generate.

9. Click Next.

10. Select the folder destination for your Web site and click Next to gen-
erate (publish) your site. Database conversion occurs during the gen-
erating process.

11. Once your Web site is generated (published), your newly created MS
Access database appears in the designated folder.
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Server Related Topics

Introduction

The sites you create using eXtendia v10.10 should be placed to run on
ASP or JSP v1.1 compatible Web servers.

Microsoft IIS (Internet Information Server) versions 3.0 and higher are
100% compatible with ASP (Active Server Pages) technology. Most large
companies have Windows 2000 or NT servers and which include ASP
components.

To host with Boomerang Software hosting service or to read more on Web
hosting services go to:
https://www.BoomerangSoftware.com/Webhosting/webhosting.htm

When you publish your Web-based application or site, eXtendia creates a
file called “For System Administrator.txt” and places it at the root folder
of your site. This file guides your server administrator through the neces-
sary steps to properly set up folders or permission or whatever is needed
to run your eXtendia site. Please make sure that the administrator reads
and performs the tasks outlined in the file.

Server Requirements

For ASP Server Side Script Applications:

The server computer where the ASP based Web application should reside
must meet the following requirements:

• Any ASP compliant Web server

• Oracle client (for working with Oracle Server)

• MDAC 2.7 (for working with MS SQL)

https://www.boomerangsoftware.com/webhosting/webhosting.htm
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• Server components from Boomerang Software (for file upload and
sendmail features)

For JSP Server Side Script Applications:

The server computer where the JSP based Web application should reside
must meet the following requirements:

• JDK (Java Development Kit) 1.3 from Sun Microsystems

• Any JSP 1.1 Compliant Web Server

• An appropriate JDBC driver compatible with the Web Server's oper-
ating system (for example sun.jdbc.odbc.JdbcOdbcDriver from Sun
Microsystems, included in JDK)

• Oracle Client or Oracle thin driver setup properly on the Web Server
computer (for working with Oracle Server)

• Server components from Boomerang Software (for file upload and
sendmail features)

The Web applications created by eXtendia were successfully tested on
following systems:

For ASP Server Side Script Applications:

OS: Windows NT 4, 2000, XP

Web Server: IIS 4.0, 5.0

Database: MS Access 97, 2000, XP (direct or ODBC)

MS SQL Server 7.0, 2000 (direct or ODBC)

Oracle Server 8.1i

For JSP Server Side Script Applications:

OS: Windows NT 4, 2000, Linux Mandrake 8.0

Web Server: Apache Tomcat 3.3.1, IBM Web Sphere 4.0, Allaire JRun 3.0

Database: MS Access 97, 2000, XP (direct or ODBC)

MS SQL Server 7.0, 2000 (direct or ODBC) (Linux and Windows)

Oracle Server 8.1i (Linux and Windows)
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Installing Proper COM Objects on the Server

The Microsoft ASP technology uses COM (Component Object Model)
objects, which are installed on your server along with the IIS. ASP pages
created by eXtendia use additional COM objects to perform other vital
tasks. Without these, your site will not be able to send email messages to
you and your customer upon receiving an order. In addition the upload
features will not work properly. These COM objects are developed by
Boomerang Software and are available for download from
www.BoomerangSoftware.com.

The “For System Administrator.txt” file guides your server administrator
and shows the steps necessary to perform proper COM objects installa-
tion on the server.

Installing Java Class Files on the Web Server

If you want to generate and publish a JSP based Web application, you must
ask your hosting service provider to download Java Class Files from
www.BoomerangSoftware.com and install them on the Web server. These
files are necessary for your Web application’s proper functioning. Ask your
server administrator to read instructions in “For System
Administrator.txt” file  which is generated with your site and installed
in your site folder.

Working with a Remote Oracle Server

In case the site application you developed with eXtendia needs to work
with an Oracle or MS SQL server located on another server, you must
contact your server System Administrator to enable certain settings.

To do this, the System Administrator must have the Oracle Client Net-
work Libraries for Oracle and MDAC (Microsoft Data Access Compo-
nents) for MS SQL, installed on the server and register a TNS. He must
set the Database Name to the appropriate Net8 connect string which is the
alias in the tnsnames.ora file. For more information on Net8, refer to
Net8 Administrator's Guide.

http://www.boomerangsoftware.com
http://www.boomerangsoftware.com
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Site Generation and Site Publish Wizard

eXtendia enables a company to build and deploy very large site or server
projects. When sites get large, the need to publish or upload to the server only
specific pages, or updated parts of the site becomes very important. eXtendia
provides extensive options that simplify this process. You can specify exactly
what you want to publish or upload. This is done through a set of wizards
where you make your selections. The Wizards list the complete resources of
your site project. You can select the ones that you want to generate and pub-
lish. The “+”, “-” boxes expand or collapse groups of resources.

To generate and publish specific parts of your site project, select File >
Generate Site  or File > Publish/Upload Site.  The site generation
Wizard provides two options:

Simple and Advanced generation modes.

The Simple Mode
Although the Simple site generation mode (Figure 3.2) is easier to use
and may apply for small site projects, we recommend that you use the
Advanced mode instead. The advanced mode provides options and takes
into account the database part of your site project. In many cases, you

Figure 4.1 The Site Generation Wizard - Choose the generation mode
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may not want to upload or publish the database of your site and avoid
overwriting the database of your site on the server.

The Simple mode enables you to perform Incremental Generation. This
implies that you should generate or publish only those files that have
changed since you did the last generation. The changed files are listed in
the site resources tree in the Incremental generation wizard. You can se-
lect to generate some of the files over again, or, uncheck and exclude
certain files. Check the “Exclude Databases” check box if you want to
generate databases later.

The Incremental generation is available during one eXtendia session, and
provided that you generate or publish the site or Web-application in the
same folder. Otherwise the Incremental generation will be disabled auto-
matically.

Note: When you perform a Site Generate or Publish function, eXtendia
creates a file called “For System Administrator.txt”. Notify the site System
Administrator to read this file and follow the instructions.

Once the System Administrator confirms that all of the necessary opera-
tions and server settings regarding the databases of your site are com-
pleted, you can then start using the site or Web-application.

Figure 4.2 Site Generation Wizard - The Simple Mode
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Figure 4.3 Site Generation Wizard - Generation Options

The Advanced Mode
The Advanced site generation mode is particularly useful when your site
uses powerful databases such as Oracle Server, MS SQL Server, or MS
Access through ODBC. Other sections of this User Guide explain how
you can use such databases.

In addition, it enables you to place your databases outside your Web site re-
sources folder on the host, to provide a higher level of security for the data.

To start the Advanced Generation Mode

1. Select the Advanced generation mode in the Site Generation Wizard
window (figure 3.1). Click Next and the Generation Options dialog
box appears (figure 3.3).

2. Select the Web Server’s operation system and the scripting language
and click Next.

Note: When you select UNIX as the OS platform the scripting language
option is automatically set to JSP.

3. The Incremental Generation dialog box appears. Choose the files that
you want to generate and click Next.
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Figure 4.4 Site Generation Wizard - The Advanced Mode

Note: If you want to generate your site without generating or publishing
databases, you may uncheck the checkbox beside the database name in
the Incremental Generation dialog box. In this case you will not need to
follow the steps described below.

4. If you have databases in your site project the Databases Generation
Mode dialog box appears. Your databases will be listed.

If you don’t have databases to be generated, then the wizard auto-
matically skips to the next Browse Destination Folder dialog box or
the Publish/Upload Site dialog box.

5. Find out which database provider is available (i.e. MS SQL, Oracle,
MySQL) on your Web application’s host computer. Select an appro-
priate database type in the Database Type drop-down box. Ask your
Web application’s host System Administrator to register as many Data
Source Names as needed to correspond to the number of databases
that you have.

6. Select the database and click Connect... The Database Connection dialog
box appears. Insert the necessary information asked in the form. Click OK.

If you are generating JSP scripts you will need to insert the database
connectivity driver and the connection string, too.
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The Connection String, sometimes refered to as URL, contains JDBC
driver specific details necessary to enable your dynamic page to con-
nect to your database server.

Example:
If your Web server system administrator has registered a DSN and
called it "DSN_NAME", and the JDBC driver available on your host
server is sun.jdbc.odbc.JdbcOdbcDriver, you have to enter
sun.jdbc.odbc.JdbcOdbcDriver in the Driver field, and
jdbc:odbc:DSN_NAME in the Connection String field.

Note: If you have encountered any problems at this phase, contact your
Web server system administrator.

7. The Browse Destination Folder dialog box is displayed. Type in the
path for your application’s resource files and click Next.

8. The wizard indicates that was successfully generated. Click Finish to
close the wizard window.

9. A text file named “For System Administrator.txt” is created and placed
in your destination folder. Notify your site System Administrator to
read this file and follow the instructions. It contains important infor-
mation about setting your databases properly.

10. Once the System Administrator confirms that all necessary opera-
tions and server permissions for your databases are completed, you
can start using your Web application.

Generate Databases in Different Locations
The previous section describes how you can generate or publish all or part of
your site or Web-based application to the server. If you choose to generate or
publish the database as well, it will be placed in the site’s destination folder.

However, if you selected to place your database or use a database which
is in a different area on the server, then check “Generate databases in
different location” check box. This will generate or upload your data-
bases in a special folder. The special instruction file “For System
Administrator.txt” will also be placed in that folder.

Now you can generate your site. Remember that if you choose this feature you
must have two FTP folders to generate the database(s) in a different location,
otherwise you may create a subfolder with a unique name in your FTP site
folder and use them both. This helps the System Administrator of the server to
easily separate and exclude all temporary database related files.



Appendix A.
License Agreement and Warranty

IMPORTANT
Opening the software package and using eXtendia indicates acceptance
of the terms of this License Agreement.

NOTICE OF COPYRIGHT
This software program package (“SOFTWARE”) is a proprietary product
incorporating elements developed by Boomerang Software, Inc. (“BOO-
MERANG”). This software is protected by copyright laws and interna-
tional treaty. You must treat the SOFTWARE like any other copyrighted
material, except that you may either make one copy of the SOFTWARE
for backup or archival purposes, or you may place the SOFTWARE on a
single mass storage device (media), such as a hard disk, provided that you
keep the original software for archival or backup purposes. Copyright
laws prohibit making additional copies of the SOFTWARE for any other
reason. You may not copy written materials accompanying the SOFT-
WARE without the express permission of BOOMERANG.

The eXtendia program, its screens, icons, sequence, and organization are
copyrighted materials of BOOMERANG. They may not be copied or du-
plicated in any medium without the written authorization of BOOMER-
ANG.

SOFTWARE LICENSE AGREEMENT
The software on the eXtendia media is licensed to the user. Before using
eXtendia, you should carefully read the terms and conditions of this Agree-
ment. This Agreement is a legal contract between you (the end user) and
BOOMERANG, governing your use of the software. If you do not agree
with these terms and conditions, please return the software with all ac-
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companying packaging materials to the vendor from who you purchased
it for refund or credit. Return policies of vendors may vary; you should
check with your vendor as to their return policy on returning unused, un-
registered software. Return of software is subject to restocking charges
and terms which will be applied and deducted from the initial cost paid by
the customer returning the software. This agreement shall also be binding
on any subsequent authorized licensee. If you have questions regarding
this Agreement, contact BOOMERANG at 617-489-3000.

A. BOOMERANG grants you the right to use one copy of the software
on a single-user computer or development machine only. Installing
the SOFTWARE on a multi-user computer or network server is a
violation of this Agreement.

B. Besides the basic Program application, this product may contain tem-
plates or Enterprise Solution Generator files that contain ASP, JSP,
HTML, .NET, databases or database structures, and other pre-designed
and pre-programmed components, collectively or singularly referred
to herein as “Additional Modules”. All such Additional Modules,
whether they are bundled with the basic program, or purchased or
received by you separately, are subject to Single Use license. The
Single Use license enables you to use the Additional Modules, cus-
tomize them, modify them, enhance or edit them and publish them
for a single end user or a customer solution. If you want to distribute,
re-sell, publish, use, or in any way transfer such Additional Modules
or their derivatives to more than one party or more than one web-
application, you can do so only after receiving written authorization
from BOOMERANG enabling you and giving you the rights to do so
referred to as “Multi-Use rights for the Additional Modules”. Con-
tact Boomerang Software for more details.

C. BOOMERANG further grants you the right to make a backup/archi-
val copy of the SOFTWARE as set forth in the Notification of Copy-
right.

D. You may not sublicense, rent, or lease the SOFTWARE, but you may
permanently transfer your license to use the SOFTWARE and ac-
companying materials by delivering to another party the original media
(that is, the CD-ROM), and original user documentation materials
comprising the SOFTWARE package. The new recipient of the SOFT-
WARE and accompanying materials accepts this Agreement and is
licensed under the terms of this Agreement upon initially using the
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SOFTWARE.

LIMITED WARRANTY / LIMITATION OF REMEDIES
BOOMERANG warrants the original media (that is, the CD-ROM) on
which the SOFTWARE is recorded to be free from defects in workman-
ship under normal use for a period of thirty (30) days from the date of
your purchase as evidenced by a copy of the original receipt of payment.
BOOMERANG’S entire liability and your exclusive remedy will be re-
placement of the media that does not meet BOOMERANG’S limited war-
ranty and is returned to BOOMERANG with a copy of the original re-
ceipt of payment. BOOMERANG will have no responsibility to replace
media that has been damaged by accident, abuse, or misapplication.

Under no circumstances including negligence, shall BOOMERANG be
liable for any incidental, special, or consequential damages that result
from use or inability to use the SOFTWARE or related user documenta-
tion, including all user documentation delivered in digital format, even if
BOOMERANG or any BOOMERANG authorized representatives have
been advised of the possibility of such damages, or that result from mis-
takes, omissions, interruptions, deletion of files, errors, defects, or delays
in operation or any failure of performance whether or not caused by events
beyond BOOMERANG’S reasonable control, including, but not limited
to, acts of God, computer failure, theft, destruction, or unauthorized use
of BOOMERANG program or services provided by BOOMERANG in
connection with the publication of the software covered by the License
Agreement.

Because any individual software title which (1) creates files combining
multimedia functionality with hypertext markup language (HTML) func-
tionality and (2) is designed to create a commercial Web site (“WEB
STORE”) to facilitate electronic commerce over the public Internet is
subject to many factors beyond the reasonable control of BOOMERANG,
including but limited to the known incompatibilities among widely-dis-
tributed programs for viewing HTML files over the public Internet and
private Internet Protocol (IP) networks, improper, insufficient, obsolete,
or inoperable hardware or software configurations on remote PC’s ac-
cessing the public Internet or private IP networks, unforeseen congestion
on the public Internet or private IP networks, failure of public telecommu-
nication transmission providers, failure of unknown third parties to de-
liver access to the public Internet or the legal or illegal use of public and
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private communication systems by unknown third parties, you are advised
to verify all work created with this SOFTWARE.

You are further advised to verify all confirmed or unconfirmed attempted
transactions from any fully identified or partially identified end user
(“CUSTOMER”) accessing the WEB STORE and strongly encouraged
to make backup copies of all files, reports, email or any other administra-
tive information generated as a result of work created with this program
or attempts to access Web sites generated through the use of this program.

BOOMERANG is in no way liable for the failure of any single electronic
commerce transaction or any series of transaction authorization failures
experienced by one or more end-user merchants using this SOFTWARE
program to sell any product or service over any public or private commu-
nication system or by an end-user attempting to access any file or Web
application through any public or private communication system to pur-
chase any product or service created by any licensed or unlicensed user
of this program.

Boomerang Software, Inc. cannot assume any responsibility or liability for
any indirect, special, incidental, economic, cover or consequential dam-
ages arising out of the use of or inability to use eXtendia or any compo-
nent of the documentation included with the program, including any and
all documentation delivered in digital format. In no case shall Boomerang
Software be liable for any amount exceeding the purchase amount paid
by a licensed user for the software.

The information contained in the eXtendia documentation is subject to
change. Except as specifically provided, Boomerang Software makes no
warranty or representation, promise or guarantee, either express or im-
plied, statutory or otherwise, with respect to this software or user docu-
mentation, including their quality, performance, merchantability, or fit-
ness for a particular purpose. No Boomerang Software dealer, agent dis-
tributor, or reseller is authorized to make revisions to this warranty.

Revisions to any component of the program or user documentation in-
cluded with eXtendia may occur as deemed necessary by Boomerang Soft-
ware, Inc. The information herein is believed to be, and is presented to be,
accurate in all respects. However, Some states do not allow the exclusion
or limitation of implied warranties or limitation of liability for incidental
or consequential damages, so the above limitation or exclusion may not
apply to you.
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When you install this program, it may set your browser’s default home
page to be www.BoomerangSoftware.com. You may change this to
another home page that you want. To change the home page in your
browser, for Internet Explorer from the menu select Tools > Internet Op-
tions, in the General (or the proper) tab’s Home Page Address field enter
the web URL address you want. For Netscape, from the menu select Edit
> Preferences, select Navigation in Category, check the Home Page set-
ting and enter the web URL you want in the Home Page Location. Email
Boomerang Software for assistance if needed.

• MS DOS, Windows, NT, Me, 2000 and XP, Internet Explorer, Active
Server Pages and True Type are trademarks of Microsoft Corpora-
tion.

• IBM is a trademark of International Business Machines Corporation.
• Navigator is a trademark of Netscape Communications.
• PhotoSuite is a trademark of MGI Software.

All other product names or trademarks identified in the user documenta-
tion accompanying this SOFTWARE are trademarks or registered trade-
marks of their respective companies. They are used in this book in an
editorial fashion only. No such use, or the use of any trade name, is in-
tended to convey endorsement or other affiliation with Boomerang Soft-
ware products.
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Appendix B.
Data Type Conversions

While converting a database to other formats, eXtendia performs the fol-
lowing data type conversions:

Converting an Oracle Database to MS Access
Oracle8i MS Access 2000
float Double
rowid ReplicationID
char (length<=255)Text else Memo
varchar2 (length<=255)Text else Memo
long Memo
number Decimal
raw Binary
mlslabel Binary
long raw Binary
blob Binary
clob Binary
nclob Binary
bfile Binary

Note:

• MS Access does not support triggers.

• Oracle indexes and primary keys are converted to Access in-
dexes and primary keys.

• Oracle foreign keys are converted to Access foreign keys, which
means the database structure remains unchanged.

Converting an MS SQL Database to MS Access
MS SQL Server 7.0 MS Access 2000
char (length<=255)Text else Memo
nchar (length<=255)Text else Memo
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varchar (length<=255)Text else Memo
nvarchar (length<=255)Text else Memo
text Memo
ntext Memo
binary Binary
varbinary Binary
image Binary
timestamp Binary
money Currency
smallmoney Currency
bit Boolean
tinyint Byte
smallint Integer
int Long Integer
bigint Decimal
float Single
real Double
decimal Decimal
numeric Decimal
uniqueidentifier ReplicationID
datetime DateTime
smalldatetime DateTime

Note:

• The Auto Number field of Access converts to the int(identity)
data type of MS SQL Server.

• Access indexes and primary keys are converted to MS SQL Server
indexes and primary keys.

• Access foreign keys are converted to MS SQL Server foreign
keys, which means the logical structure of the Access database
remains unchanged.

Converting a MySQL Database to MS Access
MySQL 3.23 MS Access 2000
tinyint Byte
smallint Integer
mediumint Long Integer
int Long Integer
bigint Decimal
real Double
float Single
double Double
numeric Decimal
decimal Decimal
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date DateTime
dateTime DateTime
bit DateTime
timestamp DateTime
time DateTime
year Long Integer
char Text
bit Byte
bool Byte
varchar Text
tinytext Memo
tinyblob Binary
text Binary
blob Binary
smalltext Memo
smallblob Binary
longtext Memo
longblob Binary
enum Memo
set Memo

Note:

• The int auto_increment data field type of MySQL is converted
to the Auto Number field of Access.

• MySQL indexes and primary keys are converted to Access in-
dexes and primary keys.

Converting an MS Access Database to Oracle
MS Access 2000 Oracle 8i
Text varchar2
Memo varchar2(2000)
Byte number(3)
Integer number(5)
Long Integer number(10)
Single number
Double number
ReplicationID rawid
Decimal number
DateTime date
Currency number(19,2)
AutoNumber number(10)
Boolean char(3)
Ole Object ————
Hyperlink raw
Binary raw
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Note:

• As Oracle has no data field type for autonumbering, eXtendia
generates sequences and triggers for emulating auto incrementing.

• Access indexes and primary keys are converted to Oracle in-
dexes and primary keys.

• Access foreign keys are converted to Oracle foreign keys, which
means the logical structure of the Access database remains un-
changed.

Converting an MS Access Database to MySQL
MS Access 2000 MySQL 3.23
Text varchar
Memo text
Byte tinyint
Integer smallint
Long Integer int
Single float
Double double
ReplicationID int
Decimal decimal
DateTime date
Currency decimal(10,2)
AutoNumber int (auto_increment)
Boolean bool
Ole Object ————
Hyperlink blob
Binary vblob

Note:

• The Auto Number field of Access converts to the
int(auto_increment) data type of MySQL.

• Access indexes and primary keys are converted to MySQL in-
dexes and primary keys.

• Current versions of MySQL do not fully support foreign keys.

Converting an MS Access Database to MS SQL
MS Access 2000 MS SQL Server 7.0
Text nvarchar
Memo nvarchar(4000)
Byte tinyint
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Integer smallint
Long Integer int
Single real
Double float
ReplicationID uniqueidentifier
Decimal decimal
Date Time DateTime
Currency money
AutoNumber int(identity)
Boolean bit
Ole Object ————
Hyperlink varbinary
Binary varbinary

Note:

• The Auto Number field of Access converts to the int(identity)
data type of MS SQL Server.

• Access indexes and primary keys are converted to MS SQL Server
indexes and primary keys.

• Access foreign keys are converted to MS SQL Server foreign
keys, which means the logical structure of the Access database
remains unchanged.
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Other Boomerang Software
Products and Services

You may purchase new product s or the upgrades for your existing product s

Visit the site for pricing and more details, or email Sales@BoomerangSoftware.com
You may also visit your computer and retail stores. Some products are sold direct.

Boomerang Software, Inc. Tel.: 617-489-3000, Fax: 617-489-1486

      www.BoomerangSoftware.com                 www.EcommerceCities.com

• eXtendia  – Your complete Web content management and E-Commerce solution for enter-
prise companies. Includes: database layer management, visual ASP generator, complete
web-authoring features, latest HTML support, script wizards, E-Commerce gateways
and more. Supports Oracle, MS SQL, MySQL, and MS Access databases.

• eXtendia Community Builder  – Includes eXtendia plus the complete on-line commu-
nity designer. Enables you to build and launch on-line communities within days. Includes:
administration and member provisions, bulletin boards, announcements, gateway E-Com-
merce back end, and other on-line community options.

• WebShop XL  – The complete tool for the serious Web or E-Commerce site developers.
Includes every software tool you need to successfully sell on the net, including selected
Web page uploads, page-hit statistics, XML compliancy, built-in Form Verification, Visual
ASP, Script Wizards, Site Manager, order processing, order verification by email, and
more. Create stunning Web sites and successfully conduct your business online using a
seamlessly integrated shopping cart. One of the most complete and affordable E-Com-
merce and Web authoring solutions ever created!

• E-Commerce Construction Kit 2.0 Deluxe  – The E-Commerce tool for everyone.
Building an online business is easy once you have the right tools. Everything you need to
create an on-line business is included, ready-to-use store templates, powerful shopping
cart creator, and on-line new merchant account applications.  This is the program for
anyone wanting to be part of the Internet revolution.

• Internet DesignShop XL  – a comprehensive Web site creation, management, and pub-
lishing program for windows (no E-Commerce functions built-in). Intended for serious
Web designers. Supports dynamic HTML, selected Web page uploads, page-hit statistics,
XML compliancy, built-in Form Verification, Visual ASP, Script Wizards, Site Manager,
and more.

• Total E-Commerce for FrontPage 2000 & 2002  – The leading complete E-Com-
merce solution for FrontPage 2000 & FrontPage 2002. Integrates perfectly with FrontPage.
Includes a powerful shopping cart, search engine, on-line new merchant account applica-
tions, on-line store administration, Access database support, order processing, order veri-
fication by email, and more.

• Total E-Commerce for FrontPage 2000 & 2002 International  – The International of
Total E-Commerce. You can conduct business internationally in over 160 different curren-
cies. Includes online merchant account applications and settlement in foreign bank accounts.

• Total E-Commerce for Dreamweaver UltraDev 4  – The leading complete E-Com-
merce solution for Dreamweaver UltraDev 4.  Integrates perfectly with Dreamweaver
UltraDev 4.  Includes a powerful shopping cart, search engine, Online new merchant
account applications, Online Store Administration, Access database support, orders pro-
cessing and verification emails, and more.

mailto:Sales@BoomerangSoftware.com
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• Data Safe & Secure  - is a Windows application that is used to encrypt and decrypt all
kinds of files on PC drives. Files can be archived in their encrypted forms or transmitted to
others. In addition to supporting a number of encryption standards, Data Safe & Secure
supports digital signatures as a means of authenticating the validity of any file before,
during, or after transmitting it to others. The application suite consists of the Data Safe &
Secure Client and Data Safe & Secure Server, which is installed and run as a server on your
network. Together they function as your network solution, and secure the exchange of
information and transmission of sensitive files on your company's computers.

• PC Safe & Secure  – Your complete Encryption and Security program for files, emails,
and any document you want to send over the Net. Excellent protection for desktop or
notebook PCs. Encrypts and protects your data from prying eyes even when hackers get
through a firewall. Send files and documents that only your intended recipient can read .
Includes: File wipe out, erase, and shredding of files to make them unrecoverable, DES and
triple DES encryption, Digital Certificates, and much more. Perfect for Corporate users
who want to protect confidential data. Excellent for home users who use DSL, modems,
and cable modems when going on-line.

• Secure Shuttle Transport SST Enterprise (Client/Server Solution)  – The leading
encryption and Instant Messaging software.  Send encrypted instant messages, Encrypted
email attachments, file transfers, voice messages, and real-time voice conversations over the
Internet, securely and privately. Includes Voice over IP, Encrypted FTP, and everything
needed to secure an entire company’s network and PCs.

• President’s Club Wallet for Pocket PC  – Contact Manager and Wallet Pocket PC
application for storing personal information such as credit cards, bank accounts, and
money accounts; the program features easy data retrieval, flexible financial data charting,
easy-to-use contact storage and a special feature that enabling you to create your own
Pocket PC photo albums!

• President’s Club Graphics for Pocket PC  – A Pocket PC Graphics application for
charting personal and business financial information.  Enables you to make 2D and 3D
charts that can visually represent data comparisons, patterns, and trends.  For example,
rather than analyze several columns of worksheet data, create one data chart that will
indicate at a glance whether sales are falling or rising over specific periods or how the actual
sales compare to the projected sales!

• Games for Pocket PC and Windows CE Devices  –  Square Shooter, Trick Track,
Twins and 5x5x5.

Additional Customer Services Include
Electronic Downloads  – Many products can be purchased as program downloads from
our Web site. You can also purchase from this Web site additional documentation (in
printed or downloadable form). Click the Download link on the home page at
www.BoomerangSoftware.com.

Web Hosting Services  – Let us host your Web or E-Commerce site. All Boomerang
servers are specifically configured to host any Web site developed using our Web and E-
Commerce products. Dedicated servers are available for hosting E-Commerce businesses.
Several hosting plans are available.

For details, visit https://www.BoomerangSoftware.com/webhosting/webhosting.htm

Other Consulting Services  – For NT/Windows 2000 environments, consulting ser-
vices for Internet or enterprise application development is available.
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